It is essential that you read through all of this document before the laboratory class

Practical 2P5

Diffusion

What you should learn from this practical class:

Science

The practical aims to familiarise you with a solution of Fick's Laws of
diffusion by studying the diffusion of carbon into austenitic iron. The
treatment makes the simplifying assumptions that the diffusion
coefficient, D, is independent of concentration and the surface and bulk
concentrations are maintained constant. The quantitative analysis of
microstructures will allow you to determine D values from solute profiles.

You will also estimate the activation energy for carbon diffusion.

Skills

e Heat treatment (pack carburisation) in furnaces will be
demonstrated.

e The microscopy will require interpretation of some complex
microstructures.

e You will gain experience in the use of image processing software
for quantitative metallography.

e Results will be processed by curve fitting; you will need to use

spreadsheet or Matlab tools to do this, according to your choice.
Safety

In the pack-carburisation demonstration, care is needed in handling hot
crucibles. This must be done using proper tongs, and wearing suitable
protection (gloves and visor). Hot materials must not be left on the

bench without a notice that they are hot and the time they were placed
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there. If metallographic preparation is done, normal safety precautions
are adequate for the etches used here, i.e. lab coat, gloves and eye

protection.
Overview of the Practical

1. The pack-carburisation of a sample of Swedish Iron (ferrite with a
very low carbon content) will be demonstrated. This is an industrial
process used for case hardening. At the temperatures used, carbon

is diffusing in single-phase austenite.

2. Metallographic sections have been prepared. You will be provided
with digital images of the structures from different experimental
conditions so that quantitative measurements of phase
areas/volumes different depths can be made using image analysis

software.

3. You will determine carbon profiles by measuring the proportions of
the constituents (e.g. primary ferrite, pearlite and primary cementite)
in the normalised structures at selected depths and then calculating

the mean carbon content for each depth.

4. Different ways will be used, and compared, to determine D from the
error function solution of Fick Laws. The results will also be used to

estimate the activation energy for carbon diffusion.

5.  You will need to plan your work and select suitable data so that

sufficient samples can be analysed in the time available.
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Experimental details

Heat treatment

The samples are small pieces of Swedish Iron; this has a low C content
and is almost entirely single-phase ferrite (some samples may contain a
small amount of pearlite in their bulk to due variations in the carbon

content).
Pack carburisation will be demonstrated:

e The samples are packed in a graphite / fireclay crucible in a
mixture of powdered charcoal and sodium carbonate activator
(10 % w/w). The carbonate releases carbon dioxide that reacts
with the charcoal give carbon monoxide and forms a carburising
gas. A lid is needed to exclude air, even while the crucible is

cooling.

e The crucible is placed in the furnace for up to 4 hours at a

temperature in the region of 1000°C.

e At the end of the carburisation the crucible is allowed to cool in the
furnace (switched off) to at least 500°C before removing from the
furnace to cool more rapidly. This leaves some uncertainty in the

time of treatment, but ensures equilibrium microstructures.

Metallography

The heat-treated samples have been cut in half transversely and

mounted, then ground, polished and etched for examination.

e After grinding, which removes the distorted metal from sawing

during coarse grinding, and polishing, the samples have been
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etched in 2% Nital. It is important to have the best possible surface
finish before etching, because the presence of scratch marks will
interfere with the subsequent image analysis procedures. The etch
time was chosen to be sufficient to show the structure clearly

across the whole carbon profile.

e The samples have a 'case’ of carburised iron of uniform depth
around the whole circumference. They have been cut to examine
the mid-section metallographically, and not the end faces. This is
because carbon diffuses into the samples from the ends as well as
from the sides. It is not possible to obtain a valid one-dimensional
diffusion profile if the carbon is diffusing into area of interest from

two different directions.

Recording and Image Analysis of Micrographs

The objective is to obtain the carbon concentration profile, which you can

analyse to obtain the diffusion coefficient for carbon.

This is done by recording optical images of the etched samples, which
will then be analysed to obtain the proportions of the microstructure

constituents, which depend on the carbon concentration.

There are samples from up to six different carburisation conditions. You
do not need to analyse images from all of these. It is expected that you
will obtain data by obtaining a suitable set of images from at least two

conditions.
Instructions for image analysis are given in Appendix A.

¢ In the images, select rectangles parallel to the surface at regular

intervals and measure the proportions of each constituent by
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selecting the areas in each rectangle that are above, or below, a

chosen threshold.

e You need to think carefully about the size and position of these
rectangles, taking the observed microstructure into account, and

consider the effects of this on your measurement uncertainty.

e Similarly, you need to think carefully about the magnification of the

images that you choose to analyse.

In principle, the image analysis should be able to estimate the proportion
of proeutectoid and eutectoid constituents present for both the
hypereutectoid and hypoeutectoid regions. However, proeutectoid
cementite formed in hypereutectoid steels gives rise to difficulties in
image processing. This cementite is mainly in the form of thin films at
the prior austenite grain boundaries, and analysis by image thresholding
cannot readily identify these. The recommended procedure is to

estimate the volume fraction of pearlite in the hypoeutectoid regions (i.e.

from near zero carbon up to about 0.8 wt.% carbon), and not to attempt
measurements in the hypereutectoid regions unless you are confident in

your identification of the microstructure constituents.

Using the iron-carbon equilibrium phase diagram, you then need to

obtain data for the atomic % carbon against depth.

Advice on the calculations and data processing needed to obtain the

carbon concentration profile is given in Appendix B.

Before you start the analysis, think about which samples will give you the
data to most accurately measure the carbon concentration profiles,
which you will need to obtain values of carbon diffusivity and the

activation energy for diffusion.
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Analysis of Results to obtain Carbon Diffusivity

If we make the assumption that diffusivity, D, can be treated as a
constant and put constant surface concentrations as a boundary

condition, Fick's laws can be solved to give:

C(x,t) = Cs — (Cs — Cy)erf (x/z\/D_)

You may assume that the carbon content at the outer edge of the sample
(Cs) corresponds to the saturation carbon content in austenite for the
temperature at which the carburisation heat treatment was carried out.
This value can be obtained from the iron-carbon phase diagram, which
can be found in any standard reference book (e.g. Bhadeshia — see
Bibliography). The bulk concentration, C,, can be estimated from the

bulk microstructure of your samples.

You can analyse a Fickian concentration profile to obtain values of the

diffusivity by three related methods:

1. A simple way to determine D is to find the depth (x) at which the
carbon concentration is half that at the surface (neglecting the
original low level in the iron by assuming that C, = 0). The error

function (erf) has a value very close to 0.5 at this point, and hence

for this depth, x = v/Dt. Thus, knowing the value of x (and t), D

may be calculated.

2. Another approximate way, if the surface concentration is uncertain,

is to take the total case depth as roughly 2 v/Dt.

3. A better way is to use the full theoretical solution and obtain a

value of D for the best fit of this function to your data. The
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sensitivity of your analysis to variations in C, can also be

considered.
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Reporting
The required report is your lab book.

You should include in this a representative image of one sample,
accompanied by explanations of the structure, a graph (or graphs)
reporting the carbon content/distance data for the analysed samples, a
table summarising your D values (obtained by the three different

methods described above), and the uncertainty in these values.

Use your data to obtain a value for the activation energy of carbon

diffusion, and report the uncertainty in this value.
In your lab book, comment on the following:

1. There is sometimes a light coloured layer at the free surface of

some samples. What do you think it is? Explain your judgement.

2. How do your values of D and the activation energy compare with
literature values? (Take due account of your estimate of the

uncertainty in your measurement).

3. The analysis assumes D is constant with carbon content. How and
why does theory predict D changes with carbon content. Do your
data agree with this? What is the analysis method by which the

value of D for any carbon content could be obtained from an

accurate carbon concentration curve?
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Appendix A: Image Analysis
You can download the free software (Fiji or ImageJ) from imagej.net

Using Fiji or ImageJ to Measure the Area Fraction of Pearlite

Open Fiji (or ImageJ) and import the image file

Open Fiji, which may also be called (Fiji is just) ImageJ. The icons are

shown in Figure 1. Both are essentially the same software.

Open your image within the software. You can usually do this by

Figure 1: Icons for Fiji and Image]

dragging the image file onto the toolbar (Figure 2). Or, choose the menu
sequence File > Open and then select the image file from the file

browser.

B O|c|o| 4| wNA|a|o| 7] xsejw]s]s]a] |>

*Rectangle*, rounded rect or rotated rect (right click to switch)

Figure 2: Fiji/Image] Toolbar. The ‘rectangular selections’ tool is chosen.
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You will then have a colour image (e.g. Figure 3) to work with.

.

A

Figure 3: Example image. The pearlite is dark (as are the grain boundaries). This image is recorded at a higher
magnification to show the detail. You may find a lower magnification is more useful for the data acquisition in this
laboratory.

Convert Colour to Greyscale

It is usually easier to threshold and segment images if they are

monochrome or ‘greyscale’, rather than colour (e.g. RGB).

Greyscale images can be 8 bit (grey intensity from 0 to 255) or 16 bit
(grey intensity from 0 to 65,535). Usually, 0 is black and the highest
number is white, but it can be the other way around. For most purposes,
8 bit is quite sufficient.
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Change the image type chose Image > Type and select 8 bit (Figure 4)

ji[i File Edit m Process Analyze Plugins Window Help
8-bit
Adjust > A
Show Info... 8! 32»?“
Properties... pgep  8-bitColor

Color » YRGB Color

Stacks > RGBStack
Hyperstacks L HSB Stack
Crop 08X Lab Stack
Duplicate... ¢ #D

Rename...
Scale...
Transform
Zoom
Overlay

Lookup Tables

Annotate
Drawing
Video Editing

Axes
Threshold
Convert

Convolve
a)

Figure 4: a) Image > Type menu commands to convert image type to ‘16 bit’ or ‘8 bit’ greyscale from ‘RGB color’;
b) converted greyscale image.

\ A% 2 VVV'VYV§

The Greyscale Histogram

You can inspect the histogram of greyscale intensities by selecting your
image (click on it) and then using the Analyse > Histogram menu
commands. This creates a chart of the number of counts of each

greyscale level, and also some useful statistics.

The histogram of greyscale intensities in the example image (Figure 5a)
shows a good range of intensities (a bit more illumination could have
been used in the original image). There is a large peak for the brighter

ferrite, and a smaller peak for the darker regions that are mostly pearlite.

If your histogram is mostly to the low or high end of the 0-255 range (e.g.
Figure 5b), then it is under or over-exposed and you may not be able to
segment it reliably. In this case, 0 is black and 255 is white. It can be

the other way around, and the principles described here apply anyway.
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I 200000 ] N 2000000 ]
0 255 0 255
Count: 786432 Min: 13 Count: 786432 Min: 156
Mean: 139.017 Max: 255 Mean: 222.153 Max: 255
StdDev: 53.670 Mode: 174 (25096) StdDev: 25.650 Mode: 237 (5687VE)
a) b)

Figure 5: Example histograms of greyscale for a) quite good image and b) over-exposed image.

Using Thresholds

To separate regions of the image that are within a chosen threshold
greyscale range, select your image (click on it) and then use Image >
Adjust > Threshold. This will open a window in which you can drag

sliders to define the range of grey levels (Figure 6).

Here we want to select the dark regions, so the lower end of the range is

‘0’ or black. The upper range selected for this image is 77'.

Click on Apply when you are satisfied with the chosen value. This will
create a binary image (Figure 7a), with only two colours (0 and 255

greyscale), as shown in its histogram (Figure 7b).
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B R B

| Darkbackground  Stack histogram

Figure 6: Example of image segmentation to select the dark regions of the image. Here, 21% of the pixels are in the
selected range of intensity

#
~ ]
= o ) T ———
) . .’ a2 0 255
' ' Count: 786432 Min: 0
Mean: 53.524 Max: 255
‘ ., StdDev: 103.845 Mode: 0 (621361)
a). .t - © <)

Figure 7: a) Segmented image after threshold selection and b) resulting histogram that has peaks at 0 and 255 only and
nothing in between

Measuring the Thresholded Area Fraction

To obtain the fraction of the image area that has been selected using the

threshold, a simple method is as follows:

Choose Analyze > Set Measurements... and click the Area Fraction
and Limit to Threshold checkboxes (Figure 8a). This sets a preference
to measure only the highlighted pixels within the rectangular selection

you made. You can also select Area. Press OK.
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Select the Rectangular Selections tool in the FiJi toolbar (Figure 2) and

drag a rectangle over the region that you want to measure (Figure 8b).

Choose Analyze > Measure to measure the area covered by the black
pixels in the rectangle. You may need to choose Window > Results to

bring the Results window forward (Figure 8c).

Area Mean gray value
Standard deviation Modal gray value
Min & max gray value Centroid
Center of mass Perimeter
Bounding rectangle Fit ellipse
Shape descriptors Feret's diameter
Integrated density Median
Skewness Kurtosis

Area fraction Stack position

Limit to threshold Display label
Invert Y coordinates Scientific notation
Add to overlay NaN empty cells

Redirect to:  None

Decimal places (0-9). 3

Help Cancel 0K

[Area [%Area [MinThr [MaxThr |
1 1.160 26.518 255 255

<)

Figure 8: Example measurement. The area fraction in the chosen threshold range within the marked rectangle is 26.5%
Alternatively, you can get the fraction of pixels below the threshold in the
whole image, directly from the threshold tool (see the example in Figure
6).
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Using Fiji/lmageJ to Stitch Images

If you want to stitch multiple images to create a montage (i.e. a single
image), it is possible to do this using the image acquisition software of

the microscope. It is also very easy to do this using FiJi/lmageJ.

To stitch images using FiJi/lmageJ: Put a sequence of overlapping
images into a folder (i.e. a ‘directory’). Via the Plugins menu, select
Stitching > Grid/Collection stitching. Choose the menu options Type
“unknown position” and Order “all files in directory”, and press OK.
The default parameters should be sufficient, but don’t forget to select the

option to Display Fusion. Browse to find your data, and then OK.

This will give you a single image, stitched from the individual images,

that may be easier to analyse.

Going Further

FiJi/lmageJ is a very powerful image processing tool that is designed for
automation and batch processing of large numbers of images to obtain
guantitative data. You don't need these capabilities for this laboratory
class, but you may like to explore what can be done. You will find many

guides on the internet, and also on the software homepage: imagej.net.

The software is free and open source!, and you can download a copy

from the software homepage to use on your own computer.

1 Schindelin, J.; Arganda-Carreras, I. & Frise, E. et al. (2012), "Fiji: an open-source platform for
biological-image analysis", Nature methods 9(7): 676-682, PMID 22743772, doi:10.1038/nmeth.2019
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Appendix B: Data Analysis

Carbon Concentration Profiles

For the diffusion analysis, you need to calculate the atomic % of carbon
as a function of distance from the sample edge, and hence obtain a

carbon concentration profile.

This is done using the iron-iron carbide phase diagram, assuming
equilibrium conditions. It is also assumed that the fraction of phases
observed in your sample is the same that existed at the higher
temperature at which it formed. Under equilibrium conditions, the
eutectoid reaction occurs at 723°C. The eutectoid composition at this
temperature is 0.8 wt% carbon, while the solubility of carbon in ferrite is
0.02 wt%. The carbon content of cementite (FezC) is 6.67 wt%.

The image analysis will give you the total number of pixels in your
selected analysis area, and the number of pixels above or below your
chosen threshold (e.g. a value between O=black and 255=white). If the
ferrite is the light phase, the proportion above the chosen threshold can
be used to calculate the area fraction of ferrite (you should consider how
your choice of the segmentation threshold gives an uncertainty in this
measurement). Assuming a binary microstructure, the area fractions of

the other constituents can then be calculated.

Assuming the area fractions of the constituents A and B in a two-
dimensional section are the same as the volume fractions in the
microstructure, the weight fraction (4,,.+,) of constituent A with density p4

and volume fraction Ay, is calculated as below.

AyyPa
Ayy,pa + Byoy,pp
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The approximate densities of pearlite, ferrite and cementite are 7.5, 7.9

and 4.0 g/cm?3, respectively.

You can use the inverse lever rule and the phase diagram to then
calculate the carbon weight concentration from the weight fractions, such

as the ferrite and pearlite content.

Finally, the atomic concentration, A,;,, IS obtained from the weight
concentrations using equation below, where A,;,m and By, are the
atomic weights of elements A and B. The atomic weights of iron and

carbon are approximately 55.9 and 12.0 respectively.

A, B
Aat% — wthPatom x 100

Awt%Batom + Bwt%Aatom

You will have a quite large number of calculations to do, particularly to
assess the measurement uncertainty in your carbon concentration data,
SO you are advised to construct a spreadsheet using software such as

Excel. However, you can use alternatives, such as Matlab, if you wish.
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Diffusion and the Error Function

A simple way to estimate the diffusion coefficient is to apply Fick’s laws
to predict the concentration profile, which is described using the error
function, and compare this to your data. Assume an initial value of the

diffusion coefficient, D and then adjust this to get the best fit.

You can judge the best fit by eye, but you should consider more

guantitative ways of comparing the data and prediction to improve the fit.
You should also consider the scatter (i.e. variability) in your data and the
uncertainty in your measurements. You can then obtain a best estimate

value of the diffusion coefficient and your confidence in it.

The solution from Fick’'s Laws, for the simple case of diffusion over time t
in one dimension x, with constant diffusion coefficient D and fixed

boundary concentrations C; and C,, is given as

C(x,t) = Cs — (Cs — Colerf (x/ zm)

The Error Function, erf, is the indefinite integral defined by the equation

Z

erf(z) = ;je'yz dy

0

The function ERF (in Excel) and erf (in Matlab) can be used to calculate

the Error Function, erf.
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